Removed some warnings, cleaned up includes, and prepared
[cascardo/gnio.git] / gnio / Makefile.am
index 62cc1bf..74098c3 100644 (file)
@@ -1,11 +1,20 @@
 NULL =
 
-INCLUDES =                                     \
-       $(SAMBA_CFLAGS)                         \
-       -I$(top_srcdir)                         \
-       -I$(top_builddir)                       \
-       $(GLIB_CFLAGS)                          \
-       -DG_DISABLE_DEPRECATED
+#INCLUDES =                                    \
+#      $(SAMBA_CFLAGS)                         \
+#      -I$(top_srcdir)                         \
+#      -I$(top_builddir)                       \
+#      $(GLIB_CFLAGS)                          \
+#      -DG_DISABLE_DEPRECATED
+
+AM_CPPFLAGS = \
+        -DG_LOG_DOMAIN=\"GLib-GIO\"                     \
+        -I$(top_builddir)                               \
+        -I$(top_srcdir)                                 \
+       $(GLIB_CFLAGS)                                  \
+        $(GLIB_DEBUG_FLAGS)                             \
+        -DG_DISABLE_DEPRECATED                          \
+        -DGIO_COMPILATION
 
 lib_LTLIBRARIES=libgnio.la