netdev-dpdk: fix mbuf leaks
[cascardo/ovs.git] / debian / control
index f5126e8..2918d06 100644 (file)
@@ -2,136 +2,289 @@ Source: openvswitch
 Section: net
 Priority: extra
 Maintainer: Open vSwitch developers <dev@openvswitch.org>
-Build-Depends: debhelper (>= 5), autoconf (>= 2.60), automake1.10, libssl-dev, pkg-config (>= 0.21), po-debconf, bzip2, openssl, libncurses5-dev, libpcre3-dev
-Standards-Version: 3.7.3
+Uploaders: Ben Pfaff <pfaffben@debian.org>, Simon Horman <horms@debian.org>
+Build-Depends: graphviz,
+               autoconf (>= 2.64),
+               automake (>= 1.10) | automake1.10,
+               bzip2,
+               debhelper (>= 8),
+               dh-autoreconf,
+               libssl-dev,
+               libtool,
+               openssl,
+               procps,
+               python-all (>= 2.7),
+               python-qt4,
+               python-twisted-conch,
+               python-zopeinterface,
+               python-six
+Standards-Version: 3.9.3
+Homepage: http://openvswitch.org/
 
 Package: openvswitch-datapath-source
 Architecture: all
-Depends: module-assistant, bzip2, debhelper (>= 5.0.37), ${misc:Depends}
+Depends: bzip2, debhelper (>= 5.0.37), module-assistant, ${misc:Depends}
 Suggests: openvswitch-switch
-Description: Source code for Open vSwitch datapath Linux module
+Description: Open vSwitch datapath module source - module-assistant version
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  This package provides the Open vSwitch datapath module source code
  that is needed by openvswitch-switch.  The kernel module can be built
  from it using module-assistant or make-kpkg.  README.Debian in this
  package provides further instructions.
+
+Package: openvswitch-datapath-dkms
+Architecture: all
+Depends: dkms (>= 1.95), libc6-dev, make, ${misc:Depends}, ${python:Depends}
+Description: Open vSwitch datapath module source - DKMS version
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
  .
- Open vSwitch is a full-featured software-based Ethernet switch.
+ This package provides the Open vSwitch datapath module source code
+ that is needed by openvswitch-switch.  DKMS can built the kernel
+ module from it.
 
 Package: openvswitch-common
-Architecture: any
-Depends: ${shlibs:Depends}, openssl, ${misc:Depends}
+Architecture: linux-any
+Depends: openssl,
+         python (>= 2.7),
+         python-six,
+         ${misc:Depends},
+         ${shlibs:Depends}
+Suggests: ethtool
 Description: Open vSwitch common components
- openvswitch-common provides components required by both openvswitch-switch
- and openvswitch-controller.
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
  .
- Open vSwitch is a full-featured software-based Ethernet switch.
+ openvswitch-common provides components required by both openvswitch-switch
+ and openvswitch-testcontroller.
 
 Package: openvswitch-switch
-Architecture: any
+Architecture: linux-any
 Suggests: openvswitch-datapath-module
-Depends: ${shlibs:Depends}, ${misc:Depends}, openvswitch-common (= ${binary:Version}), module-init-tools, procps
+Depends: kmod | module-init-tools,
+         netbase,
+         openvswitch-common (= ${binary:Version}),
+         procps,
+         python-argparse,
+         uuid-runtime,
+         ${misc:Depends},
+         ${python:Depends},
+         ${shlibs:Depends}
 Description: Open vSwitch switch implementations
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  openvswitch-switch provides the userspace components and utilities for
- the Open vSwitch kernel-based switch.  
+ the Open vSwitch kernel-based switch.
+
+Package: ovn-common
+Architecture: linux-any
+Depends: openvswitch-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: OVN common components
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
  .
Open vSwitch is a full-featured software-based Ethernet switch.
ovn-common provides components required by other OVN packages.
 
-Package: openvswitch-switch-config
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}, openvswitch-switch (= ${binary:Version}), libwww-perl, libdigest-sha1-perl
-Description: Open vSwitch switch implementations
- openvswitch-switch-config provides a utility for interactively configuring
- the Open vSwitch switch provided in the openvswitch-switch package.
+Package: ovn-host
+Architecture: linux-any
+Depends: openvswitch-switch (= ${binary:Version}),
+         openvswitch-common (= ${binary:Version}),
+         ovn-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: OVN host components
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
+ .
+ ovn-host provides the userspace components and utilities for
+ OVN that can be run on every host/hypervisor.
+
+Package: ovn-central
+Architecture: linux-any
+Depends: openvswitch-switch (= ${binary:Version}),
+         openvswitch-common (= ${binary:Version}),
+         ovn-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: OVN central components
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
  .
- Open vSwitch is a full-featured software-based Ethernet switch.
+ ovn-central provides the userspace daemons, utilities and
+ databases for OVN that is run at a central location.
 
-Package: openvswitch-switchui
+Package: ovn-docker
 Architecture: any
-Recommends: openvswitch-switch
-Depends: ${shlibs:Depends}, ${misc:Depends}, console-tools
-Description: Monitoring utility for OpenFlow switches
- The ovs-switchui utility included in this package provides a
- "front-panel display" to allow administrators to view the status of
- an OpenFlow switch at a glance.
+Depends: openvswitch-switch (= ${binary:Version}),
+         openvswitch-common (= ${binary:Version}),
+         python (>= 2.7),
+         python-openvswitch (= ${source:Version}),
+         ovn-common (= ${binary:Version}),
+         ${misc:Depends},
+         ${python:Depends},
+         ${shlibs:Depends}
+Description: OVN Docker drivers
+ OVN, the Open Virtual Network, is a system to support virtual network
+ abstraction.  OVN complements the existing capabilities of OVS to add
+ native support for virtual network abstractions, such as virtual L2 and L3
+ overlays and security groups.
+ .
+ ovn-docker provides the docker drivers for OVN.
+
+Package: openvswitch-ipsec
+Architecture: linux-any
+Depends: ipsec-tools (>=0.8~alpha20101208),
+         openvswitch-common (= ${binary:Version}),
+         openvswitch-switch (= ${binary:Version}),
+         python,
+         python-openvswitch (= ${source:Version}),
+         racoon (>=0.8~alpha20101208),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: Open vSwitch GRE-over-IPsec support
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
  .
- The ezio-term utility, also included, provides a VT100-compatible
- terminal interface for EZIO3 (aka MTB-134) 16x2 LCD displays found on
- server appliances made by Portwell.  It allows ovs-switchui to work
- with such displays.
+ The ovs-monitor-ipsec script provides support for encrypting GRE
+ tunnels with IPsec.
 
 Package: openvswitch-pki
 Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}, openvswitch-common (= ${binary:Version})
-Description: Open vSwitch public key infrastructure
+Depends: openvswitch-common (<< ${source:Version}.1~),
+         openvswitch-common (>= ${source:Version}),
+         ${misc:Depends}
+Description: Open vSwitch public key infrastructure dependency package
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  openvswitch-pki provides PKI (public key infrastructure) support for
  Open vSwitch switches and controllers, reducing the risk of
  man-in-the-middle attacks on the Open vSwitch network infrastructure.
- .
- Open vSwitch is a full-featured software-based Ethernet switch.
 
-Package: openvswitch-pki-server
-Architecture: all
-Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends}, openvswitch-pki (= ${binary:Version}), apache2
-Description: Open vSwitch public key infrastructure (HTTP server support)
- openvswitch-pki-server provides HTTP access to the Open vSwitch PKI (public
- key infrastructure) maintained on the local machine by the
- openvswitch-pki package.  This HTTP access is needed for secure and
- convenient OpenFlow switch setup using the ovs-switch-setup program
- in the openvswitch-switch package.
- .
- Open vSwitch is a full-featured software-based Ethernet switch.
-
-Package: openvswitch-controller
-Architecture: any
-Depends: ${shlibs:Depends}, openvswitch-common (= ${binary:Version}), openvswitch-pki (= ${binary:Version}), ${misc:Depends}
-Description: Open vSwitch controller implementation
- The Open vSwitch controller enables OpenFlow switches that connect to it
- to act as MAC-learning Ethernet switches.
- .
- Open vSwitch is a full-featured software-based Ethernet switch.
-
-Package: corekeeper
-Architecture: all
-Depends: tmpreaper, ${misc:Depends}
-Description: Core file centralizer and reaper
- The corekeeper package configures the system to dump all core files to
- /var/log/core.  It also deletes core files older than 7 days.
+Package: openvswitch-testcontroller
+Architecture: linux-any
+Depends: openvswitch-common (= ${binary:Version}),
+         openvswitch-pki (= ${source:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: Simple controller for testing OpenFlow setups
+ This controller enables OpenFlow switches that connect to it to act
+ as MAC-learning Ethernet switches.  It can be used for initial
+ testing of OpenFlow networks.  It is not a necessary or desirable
+ part of a production OpenFlow deployment.
 
 Package: openvswitch-dbg
 Section: debug
-Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Architecture: linux-any
+Depends: openvswitch-common (= ${binary:Version}),
+         openvswitch-switch (= ${binary:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Conflicts: openvswitch-testcontroller (<< ${binary:Version}),
+           openvswitch-testcontroller (>> ${binary:Version})
 Description: Debug symbols for Open vSwitch packages
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
  This package contains the debug symbols for all the other openvswitch-*
  packages.  Install it to debug one of them or to examine a core dump
  produced by one of them.
 
-Package: openvswitch-monitor
-Architecture: any
-Recommends: openvswitch-switch
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: Monitor utility for Open vSwitch switches
- The ovs-monitor utility included in this package monitors the
- ovs-openflowd process and the kernel datapath.  If either become
- unresponsive, it reboots the machine.
-
-Package: openvswitch-wdt
-Architecture: any
-Recommends: openvswitch-switch
-Depends: ${shlibs:Depends}, ${misc:Depends}
-Description: Watchdog utility for Open vSwitch switches
- The ovs-wdt program included in this package manages the hardware
- watchdog timer in switches based on the Portwell NAR-5520 hardware.
+Package: python-openvswitch
+Architecture: all
+Section: python
+Depends: ${misc:Depends}, ${python:Depends}
+Description: Python bindings for Open vSwitch
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
+ This package contains the full Python bindings for Open vSwitch database.
 
-Package: nicira-switch
+Package: openvswitch-test
 Architecture: all
-Depends: 
- openvswitch-common (= ${binary:Version}), 
- openvswitch-switch (= ${binary:Version}), 
- openvswitch-switchui (= ${binary:Version}), 
- openvswitch-datapath-module (= ${binary:Version}),
- corekeeper, openvswitch-monitor, openvswitch-wdt, ${misc:Depends}
-Description: Metapackage for installing a Nicira Open vSwitch switch
- Installing this package will install everything needed for a Nicira
- Portwell-based Open vSwitch switch, including monitoring and the switch UI.
+Depends: python (>= 2.7) | python-argparse,
+         python-twisted-web,
+         ${misc:Depends},
+         ${python:Depends}
+Description: Open vSwitch test package
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
+ This package contains utilities that are useful to diagnose
+ performance and connectivity issues in Open vSwitch setup.
 
+Package: openvswitch-vtep
+Architecture: linux-any
+Depends: openvswitch-common (>= ${binary:Version}),
+         openvswitch-switch (>= ${binary:Version}),
+         python,
+         python-openvswitch (>= ${source:Version}),
+         ${misc:Depends},
+         ${shlibs:Depends}
+Description: Open vSwitch VTEP utilities
+ Open vSwitch is a production quality, multilayer, software-based, Ethernet
+ virtual switch. It is designed to enable massive network automation through
+ programmatic extension, while still supporting standard management interfaces
+ and protocols (e.g. NetFlow, sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In
+ addition, it is designed to support distribution across multiple physical
+ servers similar to VMware's vNetwork distributed vswitch or Cisco's Nexus
+ 1000V.
+ .
+ This package provides utilities that are useful to interact with a
+ VTEP-configured database and a VTEP emulator.